1. Welcome to VRCat! Please note that this message board is not related to VRChat in any official manner. It is run entirely by the community, and moderated by the community. Any content present has not been reviewed by VRChat moderators or staff. Your use of these forums implies understanding of this message. Thanks!
    Dismiss Notice

Collada (.dae) file not importing into blender? Try this fix!

Discussion in 'Tutorials and Tools' started by Saintrl, Nov 30, 2017.

  1. Saintrl

    Saintrl Member

    Joined:
    Nov 18, 2017
    Messages:
    93
    Likes Received:
    37
    VRChat:
    Saintrl
    After helping someone figure out why their .dae file wasn't importing into blender on discord, I decided to write down what was needed to fix the problem. I am leaving it here on the forums for future reference so I can just direct someone to this thread instead of spending several hours explaining things.


    Check for the obvious

    So you tried to import a .dae file into blender and nothing seemed to show up? Before you assume your file is corrupted check for a few basic things.
    1. Did anything appear in the hierarchy? If yes, go over the following list:
      Source: https://www.katsbits.com/smforum/index.php?topic=936.0

      When importing Collada *.dae model files into Blender 3D and they fail to display in the 3D View (indicative of a successful import), run through the following check-list of items (assumes the imported mesh has no fundamental problems causing a failed export);
      • Make sure the correct importer is used. Depending on the version of Blender used it's possible to import two 'versions' of the Collada format, neither of which is backward/forward compatible with the other i.e., importing a *.dae file using the 1.4 import script when the model was exported using 1.3 specifications will fail Collada (note: this applies largely to Blender 2.49 or below as Blender uses the current Collada codebase as the basis for its import/export capabilities).
        Clarification: Basically the note is saying you shouldn't need to worry about using the correct importer if you have the most up to date version of blender. You should be able to import all versions of .dae files just fine.
      • Check Layers. Blender can import to the active layer (script dependent) so if the mesh is not on layer being used (any layer other than "1") it may have been placed on another (typically layer "1" if other layers are being used/model is imported to).
      • Check Grid settings. Generally speaking Blender use a smaller scale/size system than other 3D applications. This can lead to imported models being so big they appear invisible because they're outside the default camera clipping distance. Increasing camera clip will often display excessively large models (by Blenders standards).
        Notes: To find the section on changing the camera clip in the Increasing camera clip link you'll need to scroll down to "View Properties - Camera Clip"
        Your model may also just be extremely small. Try this: https://blender.stackexchange.com/questions/31766/unable-to-see-anything-after-importing-obj-file (ignore the fact that the question specifies a .obj file, the answer is still relevant)
      • Check the model. Check the model in an appropriate model viewer or other third party model viewing application capable of displaying *dae files to make sure there are no fundamental issues with the mesh itself - if it fails to appear here it's likely there is a fundamental problem causing import failure into Blender.
      If all the above still result in a broken or incomplete import than it's likely the mesh is corrupted in some fashion and will need to be re-exported from the source or possibly converted into another format that's more broadly importable (with the potential loss of any animations, materials and UVW maps).
    2. If nothing appeared in the 3d view or the hierarchy, and the model imported just fine into a model viewing application ( you can try importing the .dae file into unity to see if it works), then you'll need to troubleshoot what the problem is.

    Troubleshooting the problem

    Start by opening the System Console. If you're running the windows version of blender it should be at the top toolbar under Window->Toggle System Console. If you're using Linux or Mac, this section of the blender manual should explain how to view the system console.
    Note: if you close the System Console, blender will close as well!

    Then, try importing the .dae file again. When you attempt to do so, and nothing happens, an error message should pop up in the system console.
    systemConsoleError.jpg

    If you get an error that looks similar to:
    Code:
    Sax FWL Error: Texture with sid "Map #1-image" not found in effect with id "DefaultMaterial-fx".
    then move on to the next section.

    If you get a different error or no error try the following:
    • Start with the basics and search online for your error. There may be a solution to that error already posted somewhere.
    • Since the file worked just fine in another program the file is likely not corrupted and it could possibly be that parts of the file are not being imported so blender rejects the entire thing. (When importing into other programs it'll usually try to import as much as possible and leave out anything that doesn't work. So for example you could only import 75% of the file and only that part of the model would show up in the model viewing program.) You may want to find the model in a different file format and try using that instead as the .dae file may be missing parts of the model.
    • If you get no error message and/or blender crashes when you try to import, you may have an issue with RAM. Be sure to close anything else that's open that may be gobbling up RAM and try again. If that doesn't work, you might have a problem with your hardware or blender itself. Try reinstalling blender with the default settings and you should make sure your graphics drivers and OS are up to date. After that, you may want to report a possible bug, ask a question in blender stack exchange; basically go and seek help from the blender community as troubleshooting issues with software and hardware is outside the scope of this guide.


    Fixing the problem

    So in order to fix the .dae file, so you can import it into blender, you'll need to edit the .dae file in a text editor. Do the following:
    Reference: https://forum.kerbalspaceprogram.com/index.php?/topic/10037-blender-dae-errors/
    1. Start by opening the .dae file with a text editor. My personal preference is Notepad++ as it neatly delineates everything into separate lines instead of one big mess of text. If the .dae file doesn't show up when you're looking for it in the text editor make sure that that you have "All files" selected in the file type drop down instead of just "Text Documents .txt".
    2. Then, search for "<diffuse>" and "</diffuse>".
    3. Next you're going to need to delete everything in-between "<diffuse>" and "</diffuse>". Do not delete "<diffuse>" and "</diffuse>"!
      [​IMG] notepadExample2.jpg
      notepad++Example.jpg notepad++Example2.jpg
    4. After that you'll need to save the file. Make sure to save the file as a copy with "All types" selected in the save file type dropdown to keep the .dae file extension. The reason you're saving it as a copy, leaving the original file alone, is in case you mess up and need to go back. Don't fret though, if you accidentally save it as a .txt file (or some other text format), all you need to do is go and change the file type manually to .dae in File Explorer. (Search it up if you don't know how to rename and change file types in File Explorer, it's under file settings.)
    And that's it! Try importing the edited .dae file into blender and it should work now.

    Once you've imported the .dae file into blender you might need to assign the textures manually to each material. I also found that you may need to use the UV editor to apply the textures. If you don't know how to do that search it up or ask in the discord in #avatars.


    Hopefully anyone who is reading this will find this guide helpful. It will certainly save you from hours of frustration when you try to import a file that doesn't work.
     
    #1 Saintrl, Nov 30, 2017
    Last edited: Dec 1, 2017