1. Welcome to VRCat! Please note that this message board is not related to VRChat in any official manner. It is run entirely by the community, and moderated by the community. Any content present has not been reviewed by VRChat moderators or staff. Your use of these forums implies understanding of this message. Thanks!
    Dismiss Notice

Custom Avatar, Blend Shape/Facial Expression problems

Discussion in 'Avatars' started by M A T T I, Sep 30, 2019.

  1. M A T T I

    M A T T I New Member

    Joined:
    Sep 30, 2019
    Messages:
    1
    Likes Received:
    0
    VRChat:
    M A T T I
    So, I've been making custom avatars in blender/unity for a while but with this head that I use for my "main" the facial expressions seems to mess up the "edge" of the neck/body, look at the picture. I done serveral avatars, but only having this problem with THIS head. However, I have another avatar that uses the exact same head (Made by someone else), but dont seem to have this problem... Why is this happening? Does anyone know how to fix this? Starting to run out of ideas ;_;


    // M a t t i
     

    Attached Files:

  2. Iwannalookatattachments

    Joined:
    Aug 16, 2018
    Messages:
    19
    Likes Received:
    1
    It looks like some verts were selected while editing the blendshape. Just edit the offending blendshape and move the verts back to where they should be. If its happening on all of the blendshapes it could be that something got messed up in a decimation or when a vert was deleted. In that case you might need to load an earlier save/backup or fix the basic shape and apply it to all of the blendshapes.
     
  3. Eremite

    Eremite Member

    Joined:
    Apr 12, 2018
    Messages:
    67
    Likes Received:
    14
    VRChat:
    Eremite
    copy/pasta from my old fix for this in Blender 2.79; may be different in 2.8 but may be a good clue as to what to google.

    If blend shapes get all screwed up while editing a model (eg: body explodes into a mess of polys when previewing a shape key), here's a way to fix it. :3

    1. Select all vertices whose positions you want to reset,
    2. Execute Blend From Shape, accessible from W, Ctrl-V or Mesh > Vertices menu,
    3. Set "Basis" as shape key to blend from (by default),
    4. Set blend factor to the maximum value 1.0 (by default),
    5. Uncheck Add, so only values from "Basis" will be blended in, effectively reverting all selected vertices' position.

    Sauce: https://blender.stackexchange.com/questions/2941/revert-vertex-position-to-basis-shape-key